logo

Client Portals

If you are an existing Greenwire customer, please use one of the following links to log in.
Remote Support
Client Ticketing
Client Invoicing

Additional Support

noc@greenwireit.com
(239) 444-5522

How to Install Windows XP on a Dell Vostro 220 or Vostro 1520, the Crashless way!

Greenwire Technology Solutions > IT Tech Support Articles  > How to Install Windows XP on a Dell Vostro 220 or Vostro 1520, the Crashless way!
Vostro 220MT

How to Install Windows XP on a Dell Vostro 220 or Vostro 1520, the Crashless way!

Steps that you must perform before Windows XP will Install: Below is a narration.

Switch Hard Drive Controller from AHCI to ATA:

  1. F2 at BIOS Screen
  2. Standard CMOS Features
  3. SATA Mode: Change from AHCI to ATA

Make sure your Windows XP CD is Slipstreamed to SP2 or 3

  1. Download nLite from here
  2. Download Service Pack 3 here
  3. Use nLite to Copy files from XP CD, Slipstream and make ISO with the new disk image.

I customer brought in a machine I had ordered for them needing Windows XP. I had ordered it with Vista and assured her that everything would be okay. Well, unfortunately the hospital she works for will not support Vista. So with my foot in my mouth I put in my trusty Windows XP Home CD for customers. The machine loads up the first part of Windows Setup then crashes with a BSOD (Blue Screen of Death). Saying that I need to run chkdsk /f , along with some other information that I didn’t read. Well first thing this makes me think is SATA Controller? That’s exactly what it was.  Windows XP apparently doesn’t work well with AHCI (out of the box), so you’ll have to use the above steps to switch the machine to ATA mode in the BIOS. After that I got almost to the same place then I got a pci.sys error. Which is apparently caused by another piece of hardware not supported by Windows XP until Service Pack 2. My Slipstreamed SP3 disk is was having CD-KEY issues with the Pre SP3 OEM key so I had to slipstream a new one using nLite. Once I had those two things out of the way Windows XP SP3 installed swimmingly

Watch out on the License Keys, you may have to use SP2.

Update 28 Mar 09:

Eric reports that if you install the chipset drivers before installing the other drivers you can end up experiencing a variety of strange issues. Eric reports that you can solve the problem by installing “Desktop System Software (DSS)” which is found in the System Utilities section [under Vostro 220 on the Dell Support site]. When checking the offerings I noted that one download was recently updated and marked “Urgent”.

If you found this article helpful, please link to it from your blog, or vote it on one of the Share and Enjoy links below. Google determines quality based on your link-support! We learned this from a Cape Coral Computer Repair client

user-gravatar
Greenwire Technology Solutions
73 Comments
  • Posted at 8:32 pm, February 22, 2009

    Thanks so much for the post. Having the exact same 2 issues trying different XP install CDs that I know to be good. I bought 220 with the “FreeBSD” option as Dell charges more for Vista or the desired XP license than I can buy it separately. Was about to cancel a client appoinment and enter tech support hell but now in 45 seconds I’m back on track!

    • Posted at 1:10 am, August 30, 2009

      Most people installing XP on one of these computers are doing so in a VLK environment.

  • ModernII
    Reply
    Posted at 8:09 am, February 25, 2009

    Same here. was just starting to worry that XP would not install on Vostro 220. The recipients of this PC do not want Vista even though it should work for them. I told them before knowing of the issues that XP would be no problem. I hate eating my words so you really helped out. Thanks.

  • Posted at 5:46 pm, March 4, 2009

    Thank you for the info, I was getting worried.

  • Sean
    Reply
    Posted at 6:08 pm, March 5, 2009

    Thanks so much for this. Have been tearing my hair out trying to get XP to install and was getting the bluescreen when trying to get XP onto them – really glad I found this page. Thanks.

  • george
    Reply
    Posted at 10:04 am, March 11, 2009

    Another thank you here !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  • Matthew
    Reply
    Posted at 5:19 pm, March 11, 2009

    THANK You ! ! ! ! ! ! ! 🙂

  • Steve
    Reply
    Posted at 10:39 am, March 15, 2009

    Thank you, everything installed perfectly. But upon reboot, now I am getting “operating system missing” any clue what happened?

  • Eric
    Reply
    Posted at 9:12 am, March 18, 2009

    Using the procedures outline in the thread (thank you for the clarity) I was able to install Windows XP SP2. The Intel Chipset Drivers from Dell was installed (first update following OS install); however, the PC begins to perform oddly. The network driver has problems obtaining an IP address from DHCP, the USB devices aren’t recognized. These problems don’t occur when video and network are installed without prior installation of the chipset.

    Has anyone experienced symptoms as described or other problems following the Chipset driver install?

    • Posted at 5:04 pm, March 22, 2009

      Nah, it seemed to work find for me. It does sound like a Chipset problem though. Try getting the chipset drivers from Intel instead of Dell. By the time Dell publishes on their site sometimes they are already old.

  • Jake
    Reply
    Posted at 4:57 pm, March 22, 2009

    I am doing the same thing and the mouse and keyboard are not recognized.

    • Posted at 5:03 pm, March 22, 2009

      Try a PS/2 Mouse/Keyboard if you are using USB. and vice-versa if you’re using PS/2

  • Eric
    Reply
    Posted at 9:55 am, March 28, 2009

    The issue was resolved on my Vostro 220

    With the experience of many Dell rebuilds to my credit, I’ve never (prior to this Vostro) installed the drivers listed under “System Utilities” on the Dell website; clearly a section with a misleading name.

    In this case, after finding no other answer to the problem, I happen to read for the first time the recommended driver install order published by Dell (see link below). What is interesting is the very first item on the list – “Desktop System Software (DSS)” which is found in the “System Utilities” section. When checking the offerings I noted that one download was recently updated and marked “Urgent”.

    As it turns out, there a a few Hot Fixes included in the Utilities download. Downloading and installing this driver update corrected the issues I was experiencing.

    I suspect that many others like me, gloss over the “System Utilities” section and miss this update which includes the important Hot Fixes from Microsoft.

    http://support.dell.com/support/topics/global.aspx/support/downloads/en/driver_install_order?c=us&l=en&s=gen&~lt=print

    Shoutout for Autopatcher.com – great tool for rebuilding Windows

    • Posted at 8:31 pm, March 28, 2009

      I’ll checkout Autopatcher, seems like just the tool I’ve been looking for. Once we build nLite images it’s a pain to update it. Much easier to just send out Autopatcher CDS to customers.

  • David
    Reply
    Posted at 12:35 am, April 7, 2009

    I was having the same problem as Jake where my “USB” mouse and keyboard were not being recognized…I did a thorough check of the drivers list on Dell’s website and there it was marked as “urgent”….System Software…the site states that if you are reinstalling Windows XP, you shoud install this before the other drivers…and that did the trick!!

  • Damien
    Reply
    Posted at 10:39 am, April 14, 2009

    Thanks so much. You totally saved me.

  • greg_d
    Reply
    Posted at 4:05 pm, April 16, 2009

    Good article – it can save a lot of people a lot of time with a simple bios setting change. However it’s incorrect to say that AHCI won’t work with Windows XP. I just got 2 Vostro 220’s for my company and have been able to install Windows XP Pro SP3 using AHCI with no problem. If you use nlite to insert the required Sata Driver (downloaded from Dell) into your Windows setup cd, your blue screen of death problems with disappear and your sata drives will be recognized without issue. Granted, you can just run the system in “ATA” mode and not worry about the sata driver, but if you want the benefits of AHCI, it’s possible with a little effort.

    • Posted at 5:44 pm, April 16, 2009

      You’re absolutely right. I suppose a better way to phrase it is “Windows XP doesn’t support AHCI out of the box”.

  • Dave
    Reply
    Posted at 3:34 pm, May 4, 2009

    I found this site AFTER seeing another site that suggested switching from AHCI to ATA. So I have XP installed and the system is up and running. Is it possible to switch the mode back to AHCI now?

    I tried just making the switch in system settings at startup, but the system wouldn’t boot. It seems to be running fine in ATA, just curious if you can change after the fact. Or is it worth reinstalling the OS with the slipstreamed SATA driver now before I start loading apps and moving files.

    • Posted at 3:47 pm, May 4, 2009

      Hey I may not be understanding your question/comment right but:

      If I understand correctly, you installed Windows XP with the SATA controller set to ATA then once windows was installed switched back to AHCI?

      Did you install the dell AHCI drivers before turning on AHCI?

      Unfornunately I believe that once you switched back to AHCI you may have confused the bootloader.

      Windows XP uses the following format:

      multi(0)disk(0)rdisk(0)partition(1)WINDOWS=”Windows XP Professional” /fastdetect

      Perhaps when you changed it back to AHCI it detected it as a different controller?

      If you have the AHCI drivers correctly installed into Windows, I would try booting from an XP disk, loading the AHCI drivers during the setup then use the recovery console to run bootcfg /rebuild.

      Alternatively you can go the easy route and just slipstream the drivers into the disk. I would recommend this route if you want the benefits of AHCI otherwise it’s probably going to be a messy process.

  • Posted at 2:15 pm, May 5, 2009
  • sagar
    Reply
    Posted at 5:18 am, May 20, 2009

    i am not able to install windos xp from ghosr server.
    Please suggest on that

    • Posted at 12:42 pm, May 20, 2009

      I’m sorry, you’re going to have to provide more information.

  • Posted at 12:51 pm, May 26, 2009

    You are a God among men. First day back from vacation, setting up 3 of these machines starting off with a bluescreen was like a kick in the teeth. This made my day a lot easier thank you.

    • Posted at 1:12 pm, May 26, 2009

      Thanks for the kind words!

  • Josh
    Reply
    Posted at 2:00 pm, June 16, 2009

    Thank you so much for this post! Was the first result on google and got my windows xp install going quick and easy! Thanks again!!

  • shivam
    Reply
    Posted at 7:59 am, June 22, 2009

    thank you your geniuas

  • Alexandre
    Reply
    Posted at 7:49 pm, June 24, 2009

    Dude, you´re the best!

  • James
    Reply
    Posted at 4:38 am, June 25, 2009

    Which SATA driver do you need to download in order to switch back to ACHI?

  • Parames
    Reply
    Posted at 7:43 am, June 25, 2009

    Thank you very much. I am worried about installing Windows XP after googling around and landing on this page everything got solved.. Thanks man

  • Martin
    Reply
    Posted at 2:45 pm, June 26, 2009

    Thank you a lot, it’s very helpful!

  • Jason
    Reply
    Posted at 12:08 pm, July 17, 2009

    Thanks man, nothing like getting a new system in, building an install disk with nlite, and then promptly getting a blue screen. Nice easy work around.

  • Triamera
    Reply
    Posted at 4:01 am, July 23, 2009

    Thanks, I owe you one!

  • Ali
    Reply
    Posted at 7:08 am, August 5, 2009

    Hi, I’m curious as to the process of downgrading from Vista Business to XP is possible, I assume I still need to either change the BIOS setting from AHCI to ATA to load XP but is anyone aware if it is possible to use the Recovery method of installing XP over Vista?

    Otherwise I’ll follow your great guide 🙂

    Thanks

    • Posted at 9:55 am, August 7, 2009

      The disk the manufacturer provides may have the AHCI drivers preloaded. Although I’m not sure about this.

  • Paula
    Reply
    Posted at 9:38 am, August 5, 2009

    You are a life saver. Thanks so much for sharing.

  • Posted at 1:19 pm, August 20, 2009

    same problem here… i’ll try this! 😉

  • expiator
    Reply
    Posted at 4:20 am, August 26, 2009

    +1

  • ptp
    Reply
    Posted at 12:35 pm, August 26, 2009

    another thank you!!

  • Mikelj3
    Reply
    Posted at 12:33 am, August 30, 2009

    If you use the most current Dell XP-Pro OS disc you will not have any problems and will not need to pre install drivers for Sata, etc. For some reason it works in Optiplex 745 machines which have Sata HD’s. So, I’m not sure if you guys are using retail purchased XP-Pro, but if you’re installing in a Dell, their XP-Pro disc seems to have this issue covered.
    FYI
    Mike

  • Posted at 6:40 pm, September 9, 2009

    Great tip. Worked like a charm.

  • Scott
    Reply
    Posted at 10:15 am, September 17, 2009

    Just used Acronis to do a universal restore from vista to XP first time BOSD. Then i busted the Chipset drivers open and added them to Acronis to install when imaging. worked perfectly no problems.

  • Lost John
    Reply
    Posted at 10:32 am, October 6, 2009

    Thank You, Very Much!!!

  • Steve Irvine
    Reply
    Posted at 7:52 am, November 4, 2009

    Thanks Dude!

  • joesterm
    Reply
    Posted at 11:27 am, November 23, 2009

    Thanks – had exactly same issue. All good now!

    Jon

  • Scott
    Reply
    Posted at 10:55 am, November 26, 2009

    Thanks – had the same problems with XP.

    Machine runs so much faster than crappy vista

  • Posted at 1:57 pm, December 9, 2009

    thanks!!!

    it worked!!!!!!

  • Lord_Drake
    Reply
    Posted at 10:16 am, December 10, 2009

    That was an awesome article dude/dudette:-)

    I just wanted to report that this works on Vostro 1520 as well

  • Posted at 3:36 pm, December 17, 2009

    thank you so much dude

  • Noah
    Reply
    Posted at 11:26 am, January 4, 2010

    Thanks, you just saved my arse

  • Brian
    Reply
    Posted at 7:30 am, January 7, 2010

    Thank you so much! You’ve saved me! However, I have encountered one problem. I now can’t connect to the internet with an ethernet cable. When I had Vista I could just plug an ethernet cable in to my PC and in to the switch box in the office. I’m using a Dell Vostro 220s. Any idea why this is? Am I being daft? I’ve tried the connection wizard but it says I don’t have the right hardware? Am I missing some drivers?

  • Brian
    Reply
    Posted at 10:56 am, January 7, 2010

    Sorted it, all of the drivers needed reinstalling. Thanks!

  • Tony Spooner
    Reply
    Posted at 9:36 am, March 9, 2010

    Hi this fix was great changed the mode to ata and up it come, brill

    Tony

  • Jim
    Reply
    Posted at 11:12 pm, March 10, 2010

    Thanks for the useful information. Much appreciated.

    Disabling all the integrated hardware except USB controller and selecting PCI as the default display in BIOS got me past the pci.sys error.

  • Posted at 3:26 pm, March 19, 2010

    This is seriously great advice…. I was having issues trying to slipstream in drivers and service packs… and this seriously took care of the issue…I second Jim’s comment.

  • Posted at 10:35 am, April 6, 2010

    Hi

    I managed to downgrade to XP

    Did any managed to get all their drivers?

    I’m in need of a video and auto driver

    Email me

  • Posted at 1:51 pm, April 10, 2010

    Thanks for the help

  • Danny
    Reply
    Posted at 4:26 am, June 25, 2010

    i’m having the same problem, during installation of windows xp and i got the Blue Screen.

    i called the Dell Hotline, explained the problem to them. They then sent their Field Engineer to rectify my problem the next day. He just changed the Hard Disk and Ram and everything works fine.

    : )

  • Khan
    Reply
    Posted at 11:50 pm, June 29, 2010

    I sold a Vostro 1520 to one of my customers. trying to install Windows XP Home and or Professional, every time right after drivers load I am getting this BSOD. discussed with one of my Microsoft Guy, what he recommended was to order downgrade version of XP as this 1520 N machine doesnt come with OS.

  • Scott
    Reply
    Posted at 9:58 am, July 19, 2010

    I was getting the same problem with the blue screen when trying to format a Vostro 220s and switching the HD Controller to ATA did the trick. Thanks for the help.

    Scott

  • Bob
    Reply
    Posted at 2:46 pm, July 21, 2010

    Thanks for the info. Vostro 220 came with Windows 7. After changing the settting from AHCI to ATA, Windows XP Service Pack 3 installed smoothly. I had downloaded all of the Dell drivers from the Dell website onto a usb drive, installed them and I am not having any issues.

  • jin
    Reply
    Posted at 4:04 pm, November 12, 2010

    When I tried to downgrade, it came out this message “Setup cannot continue because the version of Window on your computer is newer than the version on the CD”
    How can I install window XP?
    Thank you

  • Takezo
    Reply
    Posted at 11:13 am, November 25, 2010

    hi everybody i have a vostro 220 i have tried 61561465168 times with 6516516 different version of xp but always same problems if i succed to see the desktop at the end of the installation i cannot entrer “my computer” i’ve installed nss and chipset in order but still same problems icones on the desktop are strange all windows is acting stengly here is my msn messenger please if someone can help me before i burn it 😛 sheesham@hotmail.com

  • Rodney
    Reply
    Posted at 8:52 pm, December 17, 2010

    Ok, I really need some advice because I just bought 2 compters for work and now we cant use them because of win7 not being compatable with some software we use. I did the procedure above and it loads all the XP intitial files and then I get this error: aic78u2.sys caused unexpected error (32768) at line 3540 in d:xpspbasebootsetupsetup.c. Does anyone have any idea how to get around that? Oh, by the way I have 2 Dell Vostro 430’s that I need this downgrade on ASAP! It will not be a fun Monday if I don’t get this working. Thanks in advance!!!!

  • Posted at 5:10 am, January 4, 2011

    Great post as always 😉

  • Posted at 3:43 pm, February 3, 2011

    Hello all,
    My pc (vostro 220) is in a really bad shape and needs an xp reinstallation.. (format c: and start from scratch) but how do I do that? I’d highly appreciate some help, I have all the CDs required.. Ive never done anything like that. Some tips from the pros, please!

    Many thanks!!!

  • Greg
    Reply
    Posted at 9:19 am, April 12, 2011

    You saved a prefectly working PC from the trash. THANK YOU!!
    AHCI and ATA sitting in a tree… WTF

  • Drew
    Reply
    Posted at 9:44 am, May 5, 2011

    Thanks for the info, even a year later it still saved me ALOT of time!!

  • darsi
    Reply
    Posted at 6:07 am, August 15, 2011

    Thanks a lot dude. I had 2 vostro 220’S sitting on my work desk and i couldn’t do anyting. Now they are working perfecty,..Thanks again

  • asad
    Reply
    Posted at 6:35 am, September 28, 2011

    Hi
    I need windows Xp drivers for vostro 1520 (del)
    asadvaisi@yahoo.com

  • Diyatha
    Reply
    Posted at 5:34 am, January 12, 2012

    Thank you ! It was really helpful… spent about 4-5 hrs on this until I found this post :(….. Cheers 🙂

  • sigifredo
    Reply
    Posted at 7:56 am, June 8, 2012

    Thanks for work, t need you

  • Kobs
    Reply
    Posted at 7:52 am, July 16, 2012

    Thank you so much !!!!!!!!!!!!!!!!
    Really helpful. Good Job.

Post a Comment

Comment
Name
Email
Website